Home > Unable To > Unable To Initialize Threads Cannot Find Class Java/lang/thread Oracle

Unable To Initialize Threads Cannot Find Class Java/lang/thread Oracle

Please email me at [email protected] Was not aware of that. -- Regards, Frank van Bortel Jul 19 '05 #4 This discussion thread is closed Start new discussion Replies have been disabled for this discussion. This tool uses JavaScript and much of it will not work correctly without it enabled. I already covered this above, and it has nothing to do with the stated problem of running the class with the standard java process http://www2.educ.umu.se/~bjorn/linux/howto/Java-HOWTO-7.html#ss7.3Similar to the first one, compile-time with Check This Out

Both systems have Oracle installed.The DBA's are trying to start a Java installtion app for Oracle on the second box, but are being given the following error:Unable to initialize threads: cannot This Article is: Labels: Linux, Other No comments: Post a Comment Newer Post Older Post Home Subscribe to: Post Comments (Atom) Arty Borulia Hi All... cd $ORACLE_HOME/JRE/bin 6. Shawn "Frank van Bortel" wrote in message news:c8**********@news2.tilbu1.nb.home.nl...

Please enter a title. So, if your package was named myPackage you would need to execute myPackage.ClientInterface instead of just ClientInterface. Listen, I'm going to support this with facts since I think that's the only way to get you to shut up. I don't need to go on to dispute the remaining references you cited.

cannot find class java/lang/Thread 843849 Jan 29, 2003 9:48 PM (in response to 843849) If you're getting this problem when you try to run the application on a PocketPC, it's probably Jesper de Jong Java Cowboy Saloon Keeper Posts: 15596 46 I like... You can not post a blank message. DELA ROSA > MCOM Department > http://www.smart.com.ph > > "The reason why evil prevail in this nation is > because > good men and good women get tired of being good

They are not using the vendor/version of java they think they are. Am I missingsomething else? I've compared $PATH for oracle user on both servers and they're identical.I have seem to have three versions of Java running, 1.2, 1.4 and 1.5. https://community.hpe.com/t5/Languages-and-Scripting/JVM-Problems-Unable-to-initialize-threads/td-p/3576952 Forum FAQ Calendar Forum Actions Mark Forums Read Quick Links View Site Leaders Who's Online What's New?

Am I missing something else? cannot find class java/lang/Thread 843849 Feb 4, 2003 7:53 PM (in response to 843849) It works!Thanks! PATH=$PATH:$HOME/bin export PATH unset USERNAME ORACLE_BASE=/u01/app/oracle; export ORACLE_BASE ORACLE_HOME=/u01/app/oracle/product/8.1.7; export ORACLE_HOME ORACLE_SID=ora1; export ORACLE_SID PATH=$PATH:/u01/app/oracle/product/8.1.7/bin; export PATH CLASSPATH=.:/u01/app/oracle/product/8.1.7/jdbc/lib/classes111.zip; export CLASSPATH LD_LIBRARY_PATH=/u01/app/oracle/product/8.1.7/lib; export LD_LIBRARY_PATH umask 022 ORA_NLS33=/u01/app/oracle/product/8.1.7/ocommon/nls/admin/data; export ORA_NLS33 NLS_LANG=american; export NLS_LANG Some other problem.

Edit the PATH environment variable and remove the path to the JRE that's included with Oracle. problem: when i tried to execute it using pjava with the emulator, i got the same message as you have posted. after that I setup jdk1.4.2.10 and run HelloWorld.java but had error: Unable to initialize threads: cannot find class java/lang/Thread. mv JRE JRE_old 4.

All of the class required is located in "C:\JINI\FYP2001\ClientAndService\jini\client" and it is packed a jar file called "jarFile.jar". his comment is here Re: Unable to initialize threads: cannot find class java/lang/Thread 796440 Sep 12, 2003 8:11 PM (in response to 796447) Warnerja is correct--you should never need to set classpath at all if For non-Sun JVMs there is no requirement about where the system classes are. Like 'java' is actually a script rather than the executable.

Is EBS for download as well? It's quick & easy. My problem is that I'm trying to install Oracle Applications 11i on a Linux box and keep getting the following error: /tmp/RapidInstall/jre/Linux/1.1.8/bin/../lib/i686/green_threads/libzip.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 http://bovbjerg.net/unable-to/unable-to-initialize-threads-cannot-find-class.php Oracle Adventures Installing Oracle XML DB ro Oracle 9.2 on HP How to Clear the List of Oracle Client Homes install on a User Machine...

Vinicius Papa - DBA Sharing Knowledge ! I have tried to modify the shortcut as you suggest. Also, this command line assumes you installed the Personal Java Emulation Environment in c:\pjee3.1.

If the latter, does that shell script possibly mess up your env vars?

My name is Arty Borulia and I'm an Oracle APPS DBA and ERP Technical Architect. Initializing Java Virtual Machine from ../stage/Components/oracle.swd.jre/1.1.8/1/DataFiles/Expanded/linux/bin/jre. MOST questions on this forum are specifically addressed at the Sun VM. 4. Advanced Search Forum Oracle Forums Oracle Database Administration I get Unable to initialize threads: cannot fine class java/lang/Thread error If this is your first visit, be sure to check out the

JAVAHOME=C:\j2sdk1.4.2_10 please tell me how to fix it. Can someone translate the error and tell me what's up?Thanks.You're missing libc.so.6; there's a bugfix on Metalink.--Regards,Frank van Bortel No - there's a support contract involved. Some programs use JAVA_HOME (note: with underscore) but the JDK and JRE itself don't use that environment variable. [ October 16, 2006: Message edited by: Jesper Young ] Java Beginners FAQ navigate here However the VM has to know where to find these somehow, right?

If you didn't, then you'll need to adjust the command line call accordingly. They think they are using Sun VM 1.4.x but instead they are actually using either an older version of Sun or using the MS version. 2. Similar topics Build RPM PHP with oci8 on Oracle 10g Database - RHEL4 If you connect to Oracle through .NET please help! Like Show 0 Likes(0) Actions 1 2 Previous Next Go to original post Actions About Oracle Technology Network (OTN)My Oracle Support Community (MOSC)MOS Support PortalAboutModern Marketing BlogRSS FeedPowered byOracle Technology NetworkOracle

Show 17 replies 15. Post Reply Bookmark Topic Watch Topic New Topic programming forums Java Java JSRs Mobile Certification Databases Caching Books Engineering Languages Frameworks Products This Site Careers Other all forums Forum: Beginning Java You are both right and wrong. 1. Setting the environment variable JAVAHOME doesn't do anything.

First of all, I had the same issue on HP-UX 11 last year with a rougue install of the JVM. This tool uses JavaScript and much of it will not work correctly without it enabled. APPS: libzip.so: symbol errno, version GLIBC_2.0 ► October (6) ► September (1) ► August (2) ► May (3) ► April (1) ► March (4) ► 2011 (38) ► November (3) ► Re: help!

Reply With Quote Quick Navigation Oracle Database Administration Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums Oracle Forums Oracle Database Administration Oracle Applications DBA Oracle Post your question and get tips & solutions from a community of 418,795 IT Pros & Developers. So for any given VM it might find the class files by itself, it might require a class path setting for rt.jar or it could require something completely different. Or they are using an unusual VM.

thanks --- "Eduardo A. You can not post a blank message. Please type your message and try again. Like Show 0 Likes(0) Actions 2.

You do not need to have C:\j2sdk1.4.2_10\jre\lib\rt.jar in the CLASSPATH.